Skip to content

Configure OCR Settings

OCR does not require you to configure any settings before use. But you can use the following settings to tailor OCR to the data and workflow needs of your project.

Set Denoiser and Spellcheck

Denoisier improves the legibility of documents that are hard to read, such as documents that were copied or faxed multiple times. Turning on Denoiser does increase the time required to process an uploaded file, so OCR gives you an additional option of Smart denoiser. Smart denoiser allows the system to selectively apply the process to documents that would benefit and reduces overall processing time.

Spellcheck helps you identify terms that may have been incorrectly entered in the original document.

  1. Under the OCR tab on the left side menu, click Settings.
  2. Under Denoiser Status, click Denoiser on to improve all documents or Smart denoiser to have the system determine what documents require the service.
  3. Under Use Spellcheck?, click Yes.
  4. Click Update Settings. OCR Denoiser

Enable Document Classification

A faxed patient record can contain multiple document types in a single PDF. Classifying these sections creates a linked table of contents for the document. You can also configure OCR to attempt to classify the document on import.

  1. Under the OCR tab on the left side menu, click Settings.
  2. Under Documentation Classification, click Classification on, or Advanced Classification.
  3. Click Update Settings.
  4. Import a document or open an existing document.
  5. To confirm OCR's classification or set the classification manually, at the top of the open document, click the pencil icon next to the greyed-out text Class: at the top of the document to reveal the Classification panel.
  6. On the panel, if your document type for the current page is listed under the Recent Classifications column, click the document type.
  7. On the panel, if your document type for the current page is not listed under the Recent Classifications column, click in the Search... field and enter a document type to locate an existing type or create a new document type.
  8. Page through the document and repeat the classification process whenever you encounter a new document type.
  9. To display the created table of contents, at the top of the screen, click the Data icon , click Document Details, and click Document Classification.
  10. Under Document Classification, click any Classification section to navigate to that page. OCR Classification

Enable Report Extraction

For common structured report types, such as a CBC panel, OCR can employ specific configurations to more accurately extract data. Any loaded extractors are automatically run against uploaded documents when you enable report extraction.

Note: To add report extractors to your project, contact your LifeOmic representative.

  1. Under the OCR tab on the left side menu, click Settings.

  2. Under Report Extraction, click Report extraction on.

  3. Click Update Settings. OCR Report

  4. To verify report extractors are operating, open a document, at the top of the screen, click the Data icon and click on the Analyzed Data Tables icon to open the Analyzed Data page.

  5. On the Analyzed Data page, look at the Extractors in Project table. If zero extractors are shown, no extractors are loaded for your project.

Additional Report Extraction Operations

All loaded extractors are automatically run against uploaded documents, but you may want to run the extractors again in the case of additional extractors being loaded after a document was originally processed or other circumstances.

  1. To remove any data in the current document generated by an extractor, click Clear All Extractor Data.

  2. To run all extractors against a document, click Run All Extractors.

    OCR Report

Use Automated Analysis to Create FHIR Data

OCR uses automated analysis to identify and highlight phrases with data potential. A different color coding designates each of the four FHIR resource types.

  1. Under the OCR tab on the left side menu, click Settings.
  2. Under Automated Analysis, click Analysis on.
  3. Click Update Settings.
  4. Import a document.
  5. At the top of the screen, click the Annotations icon and click Automated Analysis. OCR Data Analysis

  6. Hold down your mouse button and select a highlighted term.

    Tip: You can hit the select icon to extend the selection to the entire line.

  7. From the menu that appears, click the Analyze Selection icon Analyze Selection.

    The Analyze Contents menu appears with suggestions for FHIR data.

  8. Click on the most accurate suggestion. Your choice populates other fields.
    OCR Data Suggestion

  9. Go through the drop-down menus and select the most accurate options and confirm the suggested information or enter more accurate information in the fields.

  10. Once you are satisfied with the information, click Create ....
    OCR Data Field

  11. To view the created data, at the top of the screen, click the Data icon and click the Analyzed Data icon .

  12. To view tables of the suggested and extracted data, click the Data icon and click Analyzed Data Tables.
  13. To download a CSV file of the data, click Download Extracted Data. OCR Data Download

Use the Search List

In addition to a standard document search function, OCR lets you create a search list of multiple terms that you can access from any document within the project.

  1. Under the OCR tab on the left side menu, click Settings.
  2. Click Add Search List.
  3. Enter a descriptive name in the List Title field.
  4. Enter a search term or multiple search terms separated by commas.
  5. Click Add Search Term.
  6. Click Update Settings.
  7. To access the search list, open a document.
  8. Click the list icon to the right of the search field and click your choice of search lists.

    All the terms on the search list are highlighted in the document.

  9. Click the list icon to the right of the search field to display a list of search results. OCR Search List


Last update: 2020-11-19